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In this lab you’ll learn…
1. How to use the latest features in Illustrator to create compelling, cohesive icons
for user interfaces that your clients will love.
2. Strategies for designing a full set of icons that work well together.
3. Ways to visualize and draw complex icons using a combination of simple
geometric shapes.

Introduction
Hey, I’m Matt D. Smith, Owner and Design Director at Studio MDS located in
Athens, GA. Read more at http://mds.is

What To Expect
By the end of this workshop, you’ll be able to create a 12-piece UI icon set.
ICONS
• Chevron—4 icons in 1 (line)
• User (circle, rectangle, corner radius)
• Email (rectangles, path manipulation, line, corner radius)
• Settings (star shape, corner radius)
• Calendar (multiple shapes)
• Lock (shapes, corner radius)
• Edit (rectangle, path manipulation, line)
• Share (rectangle, path manipulation, line)
• Link (shapes, path manipulation)

Deciding on an icon set style
• What mood do you want to convey? Fun, serious, chunky, elegant, brand
specific, etc. Make a decision.
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• How lines, weights, shapes can effect voice and tone.
• Review examples from other apps
• Facebook
• Pinterest
• Instagram

Setting up our artboards
Keep in mind what size you’re designing for (eg. 16px, 24px, 32px, 48px, etc.)
• Create New Document by hitting ⌘ N
• Make sure Units are set to Pixels
• Set Artboard size to 24px by 24px
• Color mode should be set to RGB
• Make sure Grid by Row is selected. (First icon to the right of the artboard
input)
• Set Number of Artboards to 8
• Set Spacing to 10px
• Now press OK
• Hit ⌘ S to open the Save As modal.
• Select Desktop from the sidebar and hit ⌘ Shift N to create a new folder.
• Name the folder MAX Icons .
• Now hit ⌘ Shift N again to create a subfolder called source .
• Finally, change the Save As: field to MAX-icons-MDS-v0.1 , but replace MDS
with your own initials.
• Hit Save and then OK .

Quick Key Cheat Sheet
• F will toggle the view mode of your Illustrator document. Hit F once to go full
screen.
• Holding down Spacebar will activate the Hand Tool. I recommend using your
left thumb for this action.
• Holding down ⌘ Spacebar will activate the Zoom Tool. I recommend using your
left middle finger for ⌘ and your left pointer finger for Spacebar will zooming.
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• Drag right to Zoom In
• Drag left to Zoom Out
It’s normal to change hand position on the keyboard frequently while using
Illustrator. Kind of like driving a manual transmission—awkward at first, but you’ll
get used to it in no time.
• ⌘ 0 will zoom to the current artboard to your screen size.
• ⌘ 1 will zoom your document to 100%. Helpful to see the true size of your
design.
• ⌘ Shift H will toggle the visibility of your artboards.
• ⌘ U to toggle Smart Guide visibility. Hovering an anchor or a path will show a
corresponding label.
• M Rectangle Tool
• L Ellipse Tool
• \ Line Tool
• R Rotate Tool
• V Selection Tool
• A Direct Selection Tool
• P Pen Tool
• ⌘ D to duplicate last action
• ⌘ Shift M to activate Move Modal
• ⌘ Y to toggle Outline Mode
• ⌘ E to toggle GPU vs CPU mode. GPU is faster. CPU renders better. Work in
GPU. Preview in CPU.
• ⌘ G to group objects.
• ⌘ Shift G to ungroup objects.
• ⌘ ' to toggle gridlines.

Setting up Reference Gridlines
Gridlines aren’t absolutely critical, but they facilitate a simple framework and
provide a quick visual reference so you can make sure your icons are consistent
with one another.
• Hit ⌘ K to open Illustrator preferences
• Select Guides & Grid from the left menu
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• In the “Gridline Every:” field enter 4px
• In the “Subdivisions” field enter 8px
• Select OK
You can use ⌘ ‘ to toggle the pixel grid visibility.
The gridline sizes are mostly personal preference, but this should give you a good
starting point.

Designing a Chevron Icon
• Press ⌘ M to activate the Rectangle Tool
• Click anywhere on the first artboard (top left) and you’ll see the Rectangle modal
appear
• Enter 12px x 12px
• Press OK
• Press V to activate your Selection Tool
• Select your rectangle if it’s not selected already
• Give your rectangle a fill of [None] and a black stroke
• In the Stroke panel ( Window > Stroke ) set the “Weight” to be 2pt .
• Now select Round Cap and Round Join in the Stroke Panel (This is personal
preference depending on the style of icon set you are creating.)
• Move your rectangle to the center of your artboard
• The Smart Guides will help with alignment
• Alternatively, you can use the Align panel found under Window > Align to
center your rectangle
• With the Align panel open, press the icon in the lower right beneath the label
Align To:

and select Align to Artboard

• Now press the Horizontal Align Center , then Vertical Align Center
icons.
• Now that your rectangle is centered, hover just above the top right anchor point
until the cursor changes to a quarter-circle icon.
• Click and drag down while holding Shift to rotate 45º degrees.
• Press A to activate your Direct Selection Tool
• Select the leftmost anchor point of the rectangle and hit delete
• Press V to activate your Selection Tool and position your new icon in the center
of the artboard.
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• Now you’ve got your right chevron

Creating 3 Chevrons from 1
• Select your newly created Chevron with the Selection Tool V
• Click and Option + Shift Drag to the middle of the next artboard using its
center registration point. This will make a copy of your shape and constrain it
horizontally while you drag it into place.
• Now press the R key to activate the Rotate Tool. You’ll see the cursor change to
cross hairs. Click once on the shape’s center registration point. This defines the
point of rotation.
• Click the top anchor point of the path and drag clockwise 180º.
• Now you’ve got your left chevron
• Repeat the same steps from above to create an “Up” chevron and a “Down”
chevron on the next two artboards.
• PRO TIP: You can hit ⌘ D to duplicate any previous action in Illustrator.

Designing a Profile Icon
• Pan down to the next artboard using the Spacebar
• Press L to activate the Ellipse Tool
• Click on the artboard and you’ll see the Ellipse modal appear.
• Enter 10 x 10
• Position the new ellipse in the top center of the artboard.
• In Window > Transform , make sure that the ellipse shape has Align to Pixel
Grid

selected. This will help keep things nice and crisp.

• PRO TIP: A 2pt stroke aligned to the pixel grid will fall on a whole X and Y
coordinate, while a 1pt stroke will fall on a half pixel X and Y coordinate.
• Press M to activate the Rectangle Tool
• Click on the artboard and enter 18px x 8px
• Position the rectangle in the bottom center of the artboard
• Nudge the top circle and bottom rectangle slightly until their paths intersect on
the same horizontal line. The bottom most path of the circle should be on the
same horizontal line as the top most path of the rectangle.
• Press A to activate the Direct Selection Tool
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• Draw a section over the top left anchor point of the rectangle
• Hold Shift and select the top right anchor point
• With both of the top anchor points selected and the Direction Selection Tool still
activated, hover your cursor over the circular icon on the inside of either of the
top anchor points. Your cursor will show a small rounded path icon beside it
when it’s correctly positioned.
• Click and hold one the circular icons and drag the corners done until the radius
is maxed out at 8px.
• Now for some style points, click the rectangle’s bottom path and hit delete .
This will remove part of the rectangle, but leave the other pieces intact.

Designing an Email Icon
• Press M , click on the next artboard and enter 18px by 14px , align to pixel grid,
and position it in the center of the artboard.
• Press \ to activate the Line Tool and draw a horizontal line across the
rectangle.
• Press P to activate the Pen Tool.
• Hover your cursor over the center of the horizontal line. You should see a small
+

icon appear beside the tool tip.

• Click to add an anchor point to the center of the line.
• Press A to activate the Direct Selection Tool and select the left and right anchor
points of the line.
• Drag the line anchor points to the top corners of the rectangle shape. The Smart
Guides ⌘ U will help with alignment.
• Click off of your line to deselect it.
• Press V to activate your Selection tool and select the V-shaped line.
• Nudge your line segment down a 3 pixels with the down arrow key
• Select the rectangle with the Selection Tool
• While the rectangle is selected, press A to activate the Direction Selection tool
• Now you have a “Corners” option in the toolbar which should read 0px by
default.
• Change this value to 3px
• Nudge the line segment down using the Down arrow key if the edges now extend
beyond the bounds of the rectangle.
• Select both the line and the rectangle with and hit ⌘ G to group the elements
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Designing a Settings Icon
• Select the Star Tool from the tool panel by clicking and holding the
Rectangle Tool

and choosing Star from the options.

• Click anywhere on the next blank artboard.
• In the Star Modal, set Radius 1 to 11px , set Radius 2 to 8px , and set points
to 8 .
• In Window > Transform , make sure that the star shape selected has Align to
Pixel Grid

selected.

• Also, make sure the X and Y coordinates, as well as the height and width are
whole numbers and not decimals.
• Draw a selection around the entire star with the Direct Selection Tool A
• In the top application toolbar set Corners to 2px.
• Now, hit L for the Ellipse tool, click on the artboard and enter 6px by 6px
• Make sure the Ellipse has Aligned to Pixel Grid selected in the Transform
Panel.
• Select both the star and ellipse with the Selection Tool V .
• With both shapes selected, click the star shape again. This will increase the
selection size, indicating it has been set as a key object .
• Now use Window > Align or the align tool in the application tool bar to center
the small circle horizontally and vertically over the star shape.

Designing a Calendar Icon
• In a new artboard create an 18px by 15px rectangle, align it to pixel grid, and
position it in the center.
• Give the rectangle a corner radius of 3px .
• Create a new 3px by 5px rectangle and align it to the pixel grid.
• Press A and drag the new shape’s corner radius as far as it will go. It will max
out at 1.5px indicated in the Corners field in the application toolbar.
• Align the new rectangle’s center point with the top of the large rectangle.
Because the height has an odd number of 5px it won’t snap directly to the path,
so let it go just above.
• Nudge the rounded rectangle 4px to the left.
• Now Option + Shift Drag the new rectangle to the right 7px .
• Double click the large rectangle to enter Isolation Mode . All other objects on
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the canvas will be greyed out when Isolation Mode is activated.
• Hit ⌘ Y to view Outline Mode . This is also accessible from View > Outline
Mode .

• Press A to reveal anchor point locations.
• Zoom in tight to the top left portion of the icon using ⌘ Spacebar
• Press P to activate the Pen Tool.
• Add two points to the center of the top path of the large rectangle. Exact
location is not important, just add two.
• Now hit A and select one of the new anchor points. Now Shift Drag to align
the selected anchor point to the left of the small rounded rectangle.
• Now align the second anchor point to the right edge of the rounded rectangle.
• Click the path in between the two new anchor points and hit Delete . This
should remove ONLY the section of the rectangle between the two new anchor
points. If any other part of your rectangle has been deleted, ⌘ Z until it’s back
intact and try again.
• Let’s check our work by hitting ⌘ Y to exit Outline Mode.
• Double click anywhere on the blank canvas to exit Shape Isolation Mode.
• You should now see an empty space in the center of the left rounded rectangle.
• Now do the same thing to the path behind the right rounded rectangle.
• Double click to isolate large rectangle, ⌘ Y to view outline mode, add points,
delete path segment. Exit outline and isolation mode. Double check your work.
• Draw an 18px horizontal line and place 5px above the large rectangle’s bottom
path.
• Once the top right rounded rectangle looks like the left, select all of the shapes
with and hit ⌘ G to group.

Designing a Lock Icon
• In a new artboard draw a 16px x 14px rectangle and align to pixel grid.
• Set corner radius to 3px to match the rest of the set.
• Draw a new 8px by 6px rectangle and position it above the larger rectangle.
• Select the top two anchor points of the smaller rectangle and drag the corners
to be fully rounded at 4px .
• Draw a 4px x 4px ellipse. Align to pixel grid and position it in the center of the
large rectangle.
• Select the line tool \ and click on the artboard.
• Enter 2px for the length and 90º for the angle.
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• Position the line segment centered with, but below the ellipse.
• For any positioning issues, double check the X and Y coordinates are set to a
whole number and not a decimal.
• Select and group all of the object on the artboard.

Designing a Share Icon
• Draw a 16px x 10px rectangle and align to pixel grid.
• Select and delete the top path with the Direct Selection Tool A
• Select the bottom two anchor points and add a corner radius of 3px
• Draw a 13px vertical line, align to pixel grid, and horizontally align it with the
open rectangle shape.
• Align the line to the bottom of the open rectangle and nudge it up by 6px using
the up arrow key.
• Draw a 6px by 6px rectangle and rotate it 45º.
• Delete the bottom anchor point from the rotated square and position it at the
top of the line segment.
• Check alignment and group objects.

Designing an Edit Icon
• Draw an 16px x 16px rectangle, align to pixel grid, and round corners to 3px.
• With the Pen Tool P , add two anchor points. One to the center of the top path
and a second to the center of the right path. Make sure the + icon is showing
when you click to add a point, otherwise you’ll create a new shape. Sometimes a
⌘ Click

is required.

• Select and delete the top right anchor points of the rectangle.
• Select the top center anchor point and nudge 2px to the left.
• Select the right center anchor point and nudge 2px down.
• Draw a 4px x 4px rectangle.
• Option + Shift Drag the rectangle down 4px to create a duplicate.
• Select the bottom two anchor points with the A tool and Shift Nudge with the
down arrow key to move the anchor points down 10px. Nudge back up 2px for a
total of 8px.
• Add an anchor point to the bottom path of the tall rectangle and nudge it down
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2px .

• Select the two shapes and hit ⌘ G
• Make sure Align to Pixel Grid is NOT selected and rotate the grouped
shapes 45º. Having the pixels aligned to a grid when rotating shapes can
produce weird results.
• Select the grouped pencil shape and the open rectangle. Click the open
rectangle shape again to set it as the key object.
• Now align to the top and the right.
• Deselect all shapes.
• Select the grouped rectangles and nudge 1px up and 1px to the right.
• Select the top right anchor points of the pencil group and nudge 1px down and
1px

to the left.

Designing a Link Icon
• Draw a 12px x 8px rectangle and max out the corner radius at 8px .
• Using A , select and delete the top right anchor point.
• Select and Option + Shift Drag the shape over to the right by 7px .
• Rotate the duplicate shape 180º .
• Group the shapes.
• Select the group and rotate 45º .

Preparing Your Icons for Export
• Hit ⌘ Shift S to open the Save As modal. Save your new document as MAXicons-flattened-mds-v0.1.ai , keeping the original as a safe backup.

• Now, make sure you’re working in the Flattened file by double checking the
title bar in the top of the canvas. Toggle F a few times if you need to.
• Hit ⌘ A to select all objects on the canvas.
• In the Menu, go to Object > Path > Outline Stroke . This will convert your
stroked paths to shapes with fills.
• Select the shapes on the Profile icon artboard. You’ll notice 2 shapes
overlapping each other.
• Open the Pathfinder Window > Pathfinder and select the top left icon, Unite ,
under Shape Modes. This will unite the two shapes into one, creating one shape

11

with one fill.
• Repeat this step for the remaining artboards.
• This transforms the multi-layered icons into their own simple, flattened shape.
Perfect for SVGs.

Setting Up a Custom Quick Key for Exporting
• Go to Edit > Keyboard Shortcuts .
• Click the Tools dropdown and select Menu Commands .
• Navigate to File > Export > Export for Screens and select the Shortcut
input field.
• Enter ⌘ Option E
• Hit OK

Exporting Your Icon Assets
• Hit your new shortcut ⌘ Option E to open the Export for Screens menu.
• You’ll notice all of the artboards are named, “Artboard 1, Artboard 2, etc.” Let’s
change that.
• Click on Artboard 1 title and enter icon-arrow-right .
• Highlight the text icon-arrow- and hit ⌘ C to copy the text to your clipboard.
• Now click on Artboard 2 and hit ⌘ V to paste icon-arrow- into the artboard
name. Add the text left to make the full artboard name icon-arrow-left .
• Repeat steps for the next two arrows.
• Recommended names for the rest of the icons:
• icon-profile
• icon-email
• icon-settings
• icon-calendar
• icon-lock
• icon-share
• icon-edit
• icon-link
• Once all of the artboards are renamed, click the Folder Icon under the Export
to:

section.
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• Navigate to your MAX Icons folder on the Desktop and hit ⌘ Shift N to create
a new folder. Name it export .
• Hit ⌘ Shift N to create a subfolder called svg and hit Choose .
• Now hit Export Artboard to export SVGs of all of your icons.
Now, let’s say you need these exported as PNGs for an iPhone app you’re working
on…
- Go back to your Flattened Illustrator file and hit ⌘ Option + E’ again.
- Click the Folder Icon under the Export to: section again.
- Navigate back to your Export folder and create a new folder
called png and hit Choose .
- In the Export for Screens menu, select iOS to the right of Formats: .
- Hit the X beside the SVG line item. We don’t want SVGs in
our png folder.
- Select Export Artboard` to export the 3 different sizes of PNGs to your export

folder.

Review
All right, that does it. We’ve created a simple icon set using a variety of techniques
with simple rectangles, ellipses, and line segments.
Remember to consider why you’re designing the icons and use that information to
determine your starting grid size. In our case we used a 24px grid, but there are
times when 16px, 32px, or 48px etc. might be better.
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Next Steps
For your convenience, assets from this lab will be uploaded to http://mds.is/max/

Q&A
Hit me! If you have questions that we didn’t get to during our session, I’d be more
the happy to take the conversation to email.
→ matt@mds.is
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